Passer au contenu principal
Contactez-nous
Numéros de téléphone et heures
Centre d’aide

Explorez nos ressources d’aide en ligne

Aide

WordPress Aide

Nous avons fait de notre mieux afin de traduire cette page pour vous. La page en anglais est également disponible.

Version PHP recommandée pour WordPress

WordPress recommande de mettre à jour votre version PHP vers PHP 7.4. Avant de modifier votre version PHP, nous vous recommandons de vous assurer que vos plug-ins et votre thème sont à jour.

Remarque: PHP est le langage de programmation utilisé pour créer et gérer WordPress. Les langages de programmation tels que PHP évoluent constamment pour être plus rapides et plus sécurisés que leurs anciennes versions. La mise à jour vers une version plus récente aura un effet positif sur les performances et la sécurité de votre site.

La mise à jour de votre version PHP ne devrait pas poser de problème, mais nous ne pouvons pas garantir que ce ne sera pas le cas. Pour protéger votre site, effectuez toutes les opérations suivantes dans le cadre du changement de version de PHP:

  1. Créez une sauvegarde de votre site WordPress.
  2. Mettre à jour WordPress (les utilisateurs de Managed WordPress peuvent ignorer cette étape, car la version de WordPress est automatiquement mise à jour à chaque nouvelle version).
  3. Mettez à jour votre thème WordPress.
  4. Mettez à jour vos plug-ins WordPress.
  5. Changez la version PHP en sélectionnant les étapes qui correspondent à la plateforme d'hébergement sur laquelle votre site WordPress est hébergé ( Quel type de compte d'hébergement ai-je? ):
  6. Vérifiez que votre site fonctionne sur la bonne version de PHP en utilisant un fichier phpinfo .

En savoir plus