Passer au contenu principal
Contactez-nous
Numéros de téléphone et heures
Centre d’aide

Explorez nos ressources d’aide en ligne

Aide

GoDaddy Aide

Nous avons fait de notre mieux afin de traduire cette page pour vous. La page en anglais est également disponible.

Vérifier la compatibilité entre navigateurs pour WordPress

Les problèmes de compatibilité entre navigateurs dans WordPress sont généralement liés aux CSS. Vous remarquerez souvent ce problème lorsque vous naviguez sur votre site et que certains éléments ne sont pas au bon endroit, ne semblent pas se résoudre correctement ou ne se chargent tout simplement pas du tout.

Les sites Web WordPress plus anciens peuvent rencontrer des problèmes de compatibilité entre navigateurs. En raison des exigences strictes en matière de plug-ins et de thèmes, vous êtes moins susceptible de trouver des plug-ins ou des thèmes actuels avec ce problème.

Le navigateur Microsoft Edge vous aide facilement à exécuter des vérifications de compatibilité entre navigateurs sur votre site.

  1. Ouvrez le navigateur Edge.
  2. Utilisez le navigateur pour accéder à votre site Web.
  3. Appuyez sur la touche F12 pour charger les outils de développement.
  4. Dans la fenêtre qui apparaît, cliquez sur l’onglet Émulation.
  5. Sous Chaîne de l’agent utilisateur , sélectionnez la version du navigateur que vous souhaitez tester.

    Remarque: IE 8 est un excellent point de départ, car il s'agit d'un navigateur obsolète qui est encore couramment utilisé.

  6. Examinez votre site et notez les incohérences.
  7. Répétez les étapes 5 et 6 selon vos besoins avec les navigateurs que vous pensez rencontrer des problèmes.

Puisque WordPress lui-même est déjà optimisé pour la compatibilité entre navigateurs, votre liste d'incohérences doit pointer vers un thème ou un plug-in à l'origine du problème.

En savoir plus